Home Forums Support TBTestimonials Direct link to single testimonial gives 404

Direct link to single testimonial gives 404

This topic is: resolved

This topic contains 4 replies, has 2 voices, and was last updated by  Travis Ballard 4 years, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
Author Posts
Author Posts
April 17, 2013 at 4:53 pm #720

jimmitchell
Participant
Post count: 2

First of all, what a great plugin – thank you! I noticed this when I was reviewing crawl errors in Google Webmaster Tools. My site is at http://www.jimmitchell.co.uk and all is okay except if I try and navigate directly to an individual testimonial post e.g. http://www.jimmitchell.co.uk/testimonial/ian-fischer/. This gives a 404 error.

I have also noticed some unusual behaviour when editing my Testimonials page. I have created a page called testimonials, written a bit of blurb at the top and used the following short code:

[testimonial ID="all" OrderBy="rand"]

Whenever I make a change to the copy in the blurb at the top of the page and hit update, the slug/permalink for the page changes from “testimonials” to a random slug to one of my testimonials e.g. “ian-fischer”.

I know it’s just little niggles, but any help on this would be greatly appreciated.

Best,

~jm

April 17, 2013 at 5:21 pm #721

Travis Ballard
Keymaster
Post count: 34

Hey Jim,

Have you tried visiting your permalinks page in the admin so that your rewrite rules get flushed? You don’t have to save anything just visit the settings page for permalinks and then refresh the single testimonial link and see if that works.

As for the second issue, does the same thing happen if you use the default theme? If it still does it with the default theme you can disable your plugins one-by-one (leaving tb-testimonials) checking with each deactivation if the problem is still there or not.

If it’s still there after you follow those steps, let me know and I will look into reproducing it on my end.

Thanks, Travis Ballard

April 18, 2013 at 12:38 pm #722

jimmitchell
Participant
Post count: 2

Hi Travis,

Thanks very much for this. The permalinks flush worked a treat – one for my WP knowledge base 😉

The second issue, after your suggestion, I’ve tracked down to a plugin called “Simple Facebook Connect“. Should I contact the developer of this plugin to try and work out what the conflict is? Happy to follow any troubleshooting steps to work it out. Unless you can suggest an alternative plugin that allows FB user registration, login and Like integration?!?

Thanks again for helping me out. And I’d certainly recommend you for any plugin work for my clients in the future 😀

Best,

~jm

April 18, 2013 at 12:43 pm #723

jimmitchell
Participant
Post count: 2

Hi,

Further to my last post, it seems Facebook have released an official WP plugin, so I’m going to try that out instead…

Best,

~jm

April 18, 2013 at 1:30 pm #724

Travis Ballard
Keymaster
Post count: 34

Jim,

Glad to hear the permalink flush solved it for you.

Facebook’s plugin should do what you want I believe. You can also check out OneAll Social Login which works through a 3rd party but they offer some statistics on your logins and what not and it’s not overly difficult to integrate.

As for special development needs in the future, I would love to help! just use the Hire Me page to send me a little information about your (or your client’s) project and I will get back to you as soon as possible.

Thanks,
Travis Ballard

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.